Home : Article Detailed Page
Print Hadith Search Plug in for Firefox/Mozilla users

Hadith Search Plug in for Firefox/Mozilla users

This plug in is for firefox users only.

Your Firefox browser must be used when trying to install any of these plug ins or it will not work.

You know the search box up in the right corner:

Firefox search bar

You can now add Quran Multiple Language Search: You can get it here:

Get The Hadith Search Plug In for FireFox